本地计算机无法启动Apache故障处理

yipeiwu_com7年前PHP代码库

最近因工作需要,要学习PHP的基础编程,于是学习架设PHP工作环境。

但按照教材上介绍的那样,安装了WMAP后,一直无法运行成功。后发现Apache一直都不在运行状态。到WMAP中的Apache选项中去选择启动但无法启动。

后经高人指点,总结出如下可能性无法启动Apache:

可能情况一:

安装Apache2的路径中不能含有中文.

可能情况二:

重启Apache就会弹出出错提示框,提示"The requested operation has failed!" 然后打开服务,启动Apache2,就提示我:
"Windows不能在本地计算机启动Apache2.......并参考特定服务错误代码1"
解决:主要是在Apache的安装目录下的\conf\httpd.conf,修改httpd.conf文件下的
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#
#Listen 12.34.56.78:80
Listen 80
把80端口改成81或者其他的 ,
改成后,
#Listen 12.34.56.78:81080
Listen 8080
再重启ApacheServices就不会出现问题了
也许,这种方法对于不同版本的Apache可能有不同的解决方法,我在配置时是用的apache_2.2.11-win32-x86-no_ssl.msi版本的,其他版本的我不是很清楚,是不是这样改,在这里分享下我解决问题后的喜悦吧!

可能情况三:

因为这几星期比较忙,所以很少去搞PHP.但今天突然想起开学时写的几个关于日历的PHP程序,想改进它,所以就从服务那里启动Apache,但却出现警告说:
“windows 不能在本地计算机启动apache2。有关更多信息,查阅系统事件日志。如果这是非Microsoft服务,请与服务厂商联系,并参考特定服务错误代码1。”
试 了几次都不行,再启动MYSQL.却能成功启动.为什么就不能启动Apache呢?想想好像上次改动过httpd.conf文件.那时只是 把"AddCharset GB2312"改为"AddDefaultCharset GB2312"因为我的那些PHP程序不能取得URL中的中文字符.所以以为是这里出了问题,所以那时就改为"AddDefaultCharset GB2312",以为下次搞时再去验证行不行,所以就没有启动过Apache,直到今天启动时发现有这个问题.改回原来的"AddCharset GB2312"再次启动!却能成功启动!看来是这字符设置的问题!

可能情况四:

打开了迅雷,迅雷默认占用80端口。关闭迅雷再重启Apache服务即可!

相关文章

PHP统计数值数组中出现频率最多的10个数字的方法

本文实例讲述了PHP统计数值数组中出现频率最多的10个数字的方法。分享给大家供大家参考。具体分析如下: 该问题属于TOPK范畴,统计单词出现频率,做报表,数据统计的时会常用! php代码...

PHP实现基于回溯法求解迷宫问题的方法详解

本文实例讲述了PHP实现基于回溯法求解迷宫问题的方法。分享给大家供大家参考,具体如下: 引言 最近在leetcode上看了些算法题,有些看着很简单的很常用的东西,竟然一下子想不出来怎么求...

php+ajax无刷新分页实例详解

本文实例讲述了php+ajax无刷新分页实现方法。分享给大家供大家参考,具体如下: ajax_page_show_userinfo.php页面如下: <meta 'Conten...

php GD绘制24小时柱状图

80,250,430,134,35,60,233,90,263,225,120,59,151,677,340,221,550,300,229,97,230,123,133,87 ...

PHP上传文件时自动分配路径的方法

本文实例讲述了PHP上传文件时自动分配路径的方法。分享给大家供大家参考。具体分析如下: 网站上传文件时,如果是小的企业站,放在一个目录还没问题,当网站大了,上传的文件多了,我们就不能放在...