FastCGI 进程意外退出造成500错误

yipeiwu_com7年前PHP代码库

在一台新服务器上,安装新网站,之前只放至了一个网站。是服务器商配置好的,非集成环境。

添加了一个新站,路径都制定好了,但是在访问时出现了500错误。提示貌似是php的问题,但是之前的网站,运行的是discuz,一切正常,加了个新网站就报错。用phpinfo语句执行也是同样的错误。

经过一番百度,解决方法如下。

打开iis,应用程序池。选择右侧的设置应用程序池默认设置。



在弹出的窗口中,找到标识,点击右侧的小方块。



把值改为LocalSystem。重启IIS,即可解决。

以上所述就是本文的全部内容了,希望大家能够喜欢。

相关文章

PHP编程过程中需要了解的this,self,parent的区别

{一}PHP中this,self,parent的区别之一this篇 面向对象编程(OOP,Object Oriented Programming)现已经成为编程人员的一项基本技能。利用O...

php中session定期自动清理的方法

下文来为各位介绍PHP设置session定期自动清理的例子了,因为session默认是15分钟自动把变量给清除内存了,但有一些时间并不生效了,下面我们就来看看。 配置完成php后默认ph...

浅谈PHP的exec()函数无返回值排查方法(必看)

在安全imagemagic时 需要用到 exec很多服务器上安装失败 exec()执行外部命令失败,但没有任何错误信息。 exec执行某命令在命令行下没有问题,但是在php中就出错。这个...

php实现的读取CSV文件函数示例

本文实例讲述了php实现的读取CSV文件函数。分享给大家供大家参考,具体如下: function read_csv($cvs) { $shuang = false; $str...

php基础知识:控制结构

php的控制结构,大部分和其他主流语言,如C,Java等相同。 这里列出一些不同的以及经常被考到的细节: 1>流程控制的替代语法(pascal的风格) 主要用在if,while,f...